To Find a File


Two things are of issue here, both related. First, I have played D&D since 1976. Second, due to my terrible hand writing I was an early adopter of computers for gaming, beginning with a hand me down C64. It had a disk drive, and a printer (kinda).

I continued to upgrade into 1993 when I got a brand new Amiga 1200. I loved the Amiga and this was my second. The first being a hand me down A500. I upgrade to an Amiga 4000 after that one. All my gaming materials were done on the computer. I geeked for office toys including a Citizen 24 pin color printer,

All good things come to an end, and the Amigas wore out. I moved to Linux. I got my files translated over, an increasingly difficult task.

We come to the Dwarven Lords Religion file. A really low priority thing, it wasn’t even finished. I finally got down to it. No way no how was the OpenSUSE Leap 15.4 going to read that .afw file. I WANTED that file.

Step One: Resuscitate a 30 year old Computer, that ancient A1200 had the files on it. I hook it up, modify the desk and every thing. It fired up, coughs wheezed, the hard drive has developed errors. (You sit around for a decade.) A run of Quaterback Tools fixed the hard drive issues. Thank god that still worked.

Step Two: Open Final Writer and get the Dwarf Lords file saved as an rtf. The only possible way to move the file is via the old Zip-disk. Yea that worked too.

Step Three: Put one of my USB Zip drives on Black Beauty. No read. Open YAST, load floppy drivers that the floppy-less machine did not need. NOW it reads. Get the file on Black Beauty.

Step Four: LiberOffice will NOT open the file. Go back to the Amiga, save it as .txt. Still does not like it. I Open kate (Text editor). That loads it. I clean the file everything not text. and LibreOffice is still a prima dona over it.

Step Five: Insert the kate output into Thunderbird. Export from Thunderbird to LibreOffice, finally it takes. I start to format and I’m finishing the Religion.

The Amiga stays hooked up. I have this itch to put a 120 gig SSD in it. Yes I have the adapter. I need to kick the two SCSI drives as to why they are not working. The Zip and CD burner do.

Remember, computers make everything simpler.

I’ve found that one simple file sanitation method is to copy and paste the text into a plain text editor, and then copy paste it out of the plain text editor into another software. Tends to strip out all the software specific hidden encoding.

In any case, congrats on getting the file into workable condition!

Exactly what I did. Thunderbird is a great neutralizer. You shed size, formatting, fonts, and page preferences. And the pesky coding that was causing LibreOffice to reject the file.

Kate is a touch unstable I’ve noticed. It tends to lock up for no apparent reason. I should locate a better text editor.

This has to be the first time I’ve seen Thunderbird brought into this kind of file conversion process! I’ll say I’ve never known Kate to be unstable, but ever since Plasma was introduced KDE as a whole has been wobbling like a house of slinkies, especially in KDE5. This is over years, across distros, across computers. I put a script on my wife’s laptop to kill and restart plasmashell because it blanks the desktop so often. Still better than Windows though.

Well that explains something.

That is awesome! Moradin must certainly have been with you!

Glory to the Skill Kindler. :upside_down_face:

As an aside, I at one time owned seven Amigas. I bought the 1000 at introduction, and also owned 2 500s, a 1200, a 2000, a 3000, and a 4000. That was back when computing was fun!

1 Like

I collected them. Production wise a 500, a 1200 and a 4000. I acquired a 1000, 2000 and 3000. The three latter are under the desk.

I sadly tossed three A-500s and an Amiga CDTV that do not work anymore.

1 Like

Could you send me that script? I get that issue.

My wife has informed me it was, in fact, her previous laptop that had the desktop issue, which is why I couldn’t find the script in her current home directory. Good thing I keep her around. But I don’t recall it being fancy, just

killall plasmashell
plasmashell &

… which saved me from entering one whole command, and that’s exactly the sort of lazy that I am. A quick peek at google says that’s for kde 5, for kde 5.10+ you want

kquitapp5 plasmashell || killall plasmashell && kstart5 plasmashell

kquitapp5 is preferred but if plasmashell has truly fouled up it may timeout and you have to resort to killall anyway.

Thank you. I’ve been hitting the reset button if it goes dark. It does it less since I added obscene amounts of ram.

De nada. My wife hated it because she always had a bunch of documents open, some of them saved, and had to deal with file recovery after the forced reboot. We went through three laptops of various design before plunking down the big bucks for a System76 laptop for her, and even that freezes up maybe twice or three times a year. She had awful luck with Linux on her laptops, meanwhile I’ve got a 15+ year old HP with a dent behind the lcd panel that is rock steady. They don’t make’em like they used to.

I’m using a Thinkpad T61 from 2008. My desktop is still pretty new.

But I did mention fireing up a 30 year old Amiga. I think the SCSI drives have died.

As to lost files, Jesus is not the only one that saves. LibreOffice is very good with journaling. E-mail is the most annoying.

How do you run a script if you can’t see imputs?

Experience. :slight_smile: It helped that not everything died; mouse input was gone, but ALT+TAB would still bring a single app to bear, fullscreen and no window decoration. ALT+F2 would still bring up the dialog to run an app so I could start the terminal emulator. Failing that, CTRL+ALT+F[1-6] would still switch to a tty, although I don’t know if plasmashell would detect the GUI terminal or if it would start where you logged in from. Same with using ssh to do it remotely. Never had to get that far. But if I had to do it from memory, <ALT+F2>, konsole, , isn’t difficult to pull off without feedback.